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Overview 

Thank you for using HighPoint Storage Management Software. This software 

consists of two parts: HighPoint Storage Management Console and HighPoint 

Storage Management Service. This is a help document for HighPoint Storage 

Management Console. In order to manage RAID array through this software more 

easily, please read the help file in detail. 

 

Installation 
Please refer to the installation guide for further information. 

 

Running 

To launch the program, type in the command “hptraid” or click the corresponding 

menu in your X-Window system. When the console main window is shown, you can 

connect to a system and perform management tasks. 

 

Functions 

1. Connect to a remote computer and manage the RAID arrays 

2. User management  

3. View information of controller, channel, array and device information in the 

computer system 

4. Create a RAID array (supported RAID levels depend on controller and driver) 

5. Delete a RAID array 

6. Verify a RAID array  

7. Rebuild a RAID array 

8. Add a scheduled task to verify & rebuild a RAID array 

9. Manage spare pool and dedicated spare disks 

10. View event log 

11. View icon legend 

12. Auto-detect hot-swap disk 

13. Auto-rebuild critical array 

14. Add a disk into a critical array 
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Network 

With this software, you can connect to any system that has HighPoint Storage 

Management Service running on it. After your identity being authenticated, you can 

perform array management tasks for the connected system.   

Remote Control 

Click File->Remote Control menu in the main window to get into the Remote Control 

window. This is the default window after you launch the program. Only when you 

connect to the remote system successfully in this window can you manage the RAID 

arrays on that system. 

Add Connection 

Adds connection (System Address, Name and Port). It registers a system for 

management.  

Click the Add button on the toolbar or click Operation->New System menu to display 

the Add connection dialog box. Enter the Address, Name and Port items, then click 

OK. Be sure not to keep the Address and Port items empty. You can enter either IP 

address or computer name, but the address you entered can't be the same as the 

system address added previously. 

Modify Connection 

Modifies connection (Name and Port). You can make a successful connection with 

the remote system only when the system port you entered is coherent with the real 

system port. 

First select one of the connections you will modify in the connection list. Then click 

the Modify button on the toolbar or click Operation->Modify menu to display the 

Modify System dialog box. After modifying the system name and system port items, 

click OK.  

The System Address item can't be changed. If you insist on modifying this item, you 

must first delete this connection and then add a new connection. Neither can you 

modify the connected system unless you disconnect it first and then modify it. 

Delete Connection 

Deletes the connection from the connection list. 

First select one of the connections you will delete in the connection list. Then click 

the Delete button on the toolbar or click Operation->Delete menu to pop up a 

confirmation dialog box. Click Ok to delete the system record. You can't delete the 

connected system unless you disconnect it first. 
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Connect Remote System 

Click the Connect button on the toolbar or click Operation->Connect menu to 

present the Login Form dialog box (See below). If you have already connected to 

another system, the current connection will be disconnected before establishing the 

new connection. 

 

Enter System Address (either host name or IP address), System Port, User Name 

and Password, then click OK. The application will execute the remote connection and 

show the current connection status. Once the connection status shows “Connected”, 

the connection process is over. Then you can use HighPoint Storage Management 

Console to manage the remote RAID array. 

When you install the service of this software for the first time, the initial User Name 

is RAID, Password is hpt. It is strong recommended to modify the initial password.  

 

Note 

l System Port value must be the same as one on the HighPoint Storage 

Management service. 

l The service only supports one client connection at one time.  

Disconnect Remote System 

If your computer is connecting to some remote system, click the Disconnect button 

on the toolbar or click Operation->Disconnect menu to pop up a confirmation dialog 

box. Click OK to terminate the current connection. 
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System Configuration 

Click File->System Configuration menu in the main window. The System 

Configuration window pops up (see below).  

 

System Port 

This is the TCP port number for the HighPoint Storage Management Service to 

communicate with management console. When you connect to the service, the port 

value you enter must be in accordance with the system port value on the service. 

The default value is 7402. 

 

Event Port 

The client software will retrieve events through this port. The default value is 7403.  

System Port must not be the same as Event Port. After you reset a system’s 

configuration, you should restart the service on that system for the changes to take 

effect. 
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User Management 

Click File->User Management menu to display the User Management window (See 

below). 

 
You can view all legal users in the current connected system. You can also perform 

add/delete/set password/set privilege operation. 

l : The current user.  

Add User 

Clicking the Add button will enter into the Add User dialog. 

To add a new user: 

(1) Enter User Name, password and confirm it. 

 

 

(2) Set user privilege. 
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If the new user is added successfully, it will appear in the User Management Window. 

Otherwise an error message will be displayed. 

Delete User 

Select a user from the user list box, and click the Delete button. The selected user 

will be deleted. If the user is now connecting to the remote computer, it can't be 

deleted. 

Set Password 

Select a user from the user list box, and click the Password button. Or you can click 

File->Password menu to modify the current password. 

Set Privilege 

Select a user from the user list box, and click the Privilege button to pop up the User 

Privilege View dialog box. You can view and modify the related privilege of this user.  
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Management 

The RAID management functions are listed under Management menu in the main 

window. The submenus below make the connected RAID system configuration 

convenient by allowing managing and monitoring of the entire device tree 

"at-a-glance." 

Array Management 

Click the Management->Array Management menu to activate a window, in which 

you will view all logical disks grouped by physical disks are listed in a treelike 

structure. When any disk is selected, the right pane will show the corresponding 

detailed information. If you select an array, you can operate the array via the toolbar 

or the Operation menu. 

Create array 

If you have Create RAID privilege and there are enough single disks in the system to 

create an array, click the Create button on the toolbar or select the 

Operation->Create menu to enter into the Array Creation wizard window. 

  

Step 1: Choose the array type you want to create from the drop-down list. The 

available array types may vary; it depends on the controller and driver you use. 

Next, enter array name. You can't leave Array Name item empty. Then click the Next 

button. If the array type is JBOD, you can directly jump to the step 3. 
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Step 2: If the array type you choose is RAID 1, you will choose either of the creation 

options (See below). 

 
RAID 1 Create Option: 

1. Create only 

The RAID 1 array created in this way will lose all data on the member disks. 

2. Create and duplicate 

Create a RAID 1 array and copy data from the source disk to the mirror disk. The 
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capacity of the source disk mustn't be larger than the mirror disk. 

Only create and duplicate a RAID 1 array can keep data on the source disk complete, 

while create any other types of arrays will lose all data on the member disks. 

If the array type is RAID 0, RAID 0/1 or RAID 1/0, you need to select the block size 

from the drop-down list. Larger block sizes are better for random disk access (like 

email, POS, or web servers), while smaller sizes are better for sequential access.  

 
If the array type you choose is RAID 5, you will choose the creation options and 

block size (See below). 
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RAID 5 Create Option: 

1. Zero Build 

This method requires each and every stripe in the RAID 5 array to be zeroed out. 

Note that, the result of an XOR on a set of zeros is also zero. Consequently this 

method of initialization permits parity to be determined and written to disks during 

the regular operation of the array (in response to write operations) using the 

"read-modify-write" method. 

2. Scrub (build parity) 

This method requires the parity of each and every stripe to be evaluated and written 

to the appropriate location on the RAID array. A “scrub” may be performed on an 

un-initialized array (i.e., an array with un-initialized disks) so that parity can be 

determined and written to disks during the regular operation of the array (in 

response to write operations) using the “read-modify-write” method. 

3. No Build 

This method assumes that a RAID 5 array is already in a consistent state with 

respect to the parity information contained in it. This is an initialization method that 

is typically employed in scenarios where the data and parity in the disks comprising 

an array are in a consistent state. For instance, all the drives may be zeroed out 

already by the manufacturer, thereby making them suitable for initialization using a 

no build. This method is however unsuitable for use when data in the disks used for 

building the array cannot be relied upon to be in a consistent state, i.e., the parity 

data is comprised of invalid values. 

Step3: Select the single disks from the Available Disks list box and add them to the 

Selected Disks list box. If you create and duplicate a RAID 1 array, the first selected 

and added to the selected disks is the source disk. If you create only a RAID 1 array, 

the software will auto-select a disk as a source disk. Finally click Finish to complete 

creating an array. 
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Rename array 

Click the Management->Array Management menu. Select the array you want to 

rename from the tree form, then click the Rename button on the toolbar or the 

Operation->Rename menu. Enter the new array name in the pop-up window and 

then click OK. If this button or the menu is disabled, then this array can't be 

renamed or you have not Rename Array privilege.  

Note 

The rebuilding/verifying/initializing/duplicating array can't be renamed.  

Delete array 

Click the Management->Array Management menu. Select the array you want to 

delete from the tree form, then click the Delete button on the toolbar or the 

Operation->Delete menu to do deletion. If this button or the menu is disabled, then 

this array can't be deleted or you have not Delete RAID privilege. 

Note 

The bootable array or the rebuilding/verifying/initializing/duplicating array can't be 

deleted. 

Add disk to array 

Click the Management->Array Management menu. If an array is broken, it's 

necessary to add single disks to it. Select a broken array, then click the Add Disk 

button or the Operation->Add Disk menu. If this button or the menu is disabled, 

then this array can't be added with disks or you have not the privilege. When the 
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system detects some physical disks, a dialog box appears. You can select a single 

disk and add it into the broken array. If the array is still broken, repeat adding the 

single disks into it. When the array's status changes to be unbroken, the system will 

auto-rebuilding the array.  

Verify array 

Click the Management->Array Management menu. If you want to verify data on an 

array, you can use this function. If you want to verify the RAID 1/0 array, you should 

operate the sub-RAID 1 array in RAID 1/0 array. Select an array from the tree form 

and then click the Verify button on the toolbar or the Operation->Verify menu. If this 

button or the menu is disabled, then you can't verify this array or you have not 

Verify RAID privilege. RAID 5, RAID 1, RAID 0/1 and sub-RAID 1 in RAID 1/0 can run 

this function. You can make Task Schedule to regularly verify the array.  

Rebuild array 

Click the Management->Array Management menu. A critical RAID 5, RAID 1, RAID 

0/1 array or a RAID 1/0 member can run this function. Select the array in the tree 

form, and click the Rebuild button on the toolbar or the Operation->Rebuild menu. 

If this button or the menu is disabled, either the array can't be rebuilt or you have 

not Rebuild RAID privilege. 

Abort rebuilding/verifying/initializing/duplicating 

Click the Management->Array Management menu. To abort a 

rebuilding/verifying/initializing/duplicating process, select the array from the tree 

form and then click the Abort button or the Operation->Abort menu. If this button or 

the menu is disabled, the array task can't be aborted or you have not the privilege. 
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Device Management 

Click the Management->Device Management menu in the main window to display 

the Device Management window. In this window, all the physical devices (including 

Controller, Channel and other Device) are linked together in a form of treelike 

structure. When any device is selected, the right pane will show the corresponding 

detailed information. 

Rescan Devices 

Click the Rescan Devices button or the Operation->Rescan Devices menu to rescan 

all the physical devices attached to the controller.  
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Spare Management 

Click the Management->Spare Management menu, the Spare Management window 

appears (see below). 

 

Assign to the spare pool 

Choose the Assign to spare pool option, the Available Disks list box will display all 

single disks in the system and the Spare Pool list box will display all the added spare 

disks. When the array is critical, the system will auto-select a spare disk to take over 

the fault disk and then rebuild the array to the original status. 

To add a spare disk, select it from the Available Disk list box and click the right arrow 

button to add the disk to the Spare Pool list box. 

To remove a spare disk, select it from the Spare Pool list box and click the left arrow 

button to remove the disk from the Spare Pool list box. 

Assign to the dedicated array 

If the controller driver supports dedicated spare, you can choose “Assign to a 

dedicated array” option to add a dedicated spare for an array. You need to select an 

array for this operation. When an array is selected, the Available Disks list box will 

display all single disks in the system and the Array Spares list box will display all 
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added dedicated spare disks. 

To add/remove a dedicated spare disk, you can perform the same operations as 

adding/removing a spare disk (see above). 
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Event Notification 

Click the Management->Event Notification menu in the main window, the E-mail 

Notification window appears. When an event occurs, the system will send e-mail to 

those preset mailboxes according to the different event types (Information, 

Warning and Error). 

E-mail notification setting 

In order to send e-mail, you should first have an available SMTP server. The 

software does not support SMTP servers that require user authentication. 

Clicking the Setting button on the toolbar or the Operating->Setting menu will bring 

up the following E-mail notification setting window. 

 

Check Enable E-mail Notification option and enter Mail From, SMTP Server and Port 

options, and then click OK. 

Add Recipient 

Click the Add button on the toolbar or the Operation->Add menu will pop up the Add 

recipient window (see below). 

 
Enter an e-mail address, the recipient name and notification options. The e-mail 
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address entered can't be repeated with the previous e-mail address. There are three 

types of event notification: Information, Warning and Error. You can select either 

one or two, even all of them.  

Modify Recipient 

Select the recipient that you want to modify from the recipient list in the Event 

Notification window. Then click the Modify button on the toolbar or the 

Operation->Modify menu. The Modify Recipient window appears. Modify the 

recipient name and the notification options. Finally click OK. 

Delete Recipient 

Select the recipient that you want to delete from the recipient list in the Event 

Notification window. Then click the Delete button on the toolbar or the 

Operation->Delete menu. Click OK on the pop-up confirmation dialog box. 

Test 

Sends a testing mail to the recipient. Select one recipient from the recipient list in 

the Event Notification window. Then click the Test button on the toolbar or the 

Operation->Test menu. If you fail to send this mail, you will get a pop-up error 

message. 
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Task Management 

Click the Management->Task Management menu in the main window, the following 

Task Management window appears.  

 
When you want to regularly verify/rebuild an array, you can make a new task 

schedule. The Task schedule list shows all added tasks. Select one task and click the 

Details button will display the detailed information of the selected task. If you have 

the privilege, you can add, modify or delete the task.  

Add Task Schedule 

There are two types of task that can be scheduled: Verify Array and Rebuild Array. 

If there are some arrays that can be verified or rebuilt in the current system, click 

the New button on the toolbar to pop up the New Task Schedule Wizard window (see 

below). 
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Select task type and array that you want to verify or rebuild from the available 

arrays drop-down list. Then click Next. 

 
In this window you will configure the frequency you want to verify or rebuild the 

specified task. 

To add a new task:  

1. Enter a name for the task. You can also use the default task name. 

2. Set Frequency. If you want to add a task to rebuild an array, you can select Occur 

one time option. If you want to add a task to verify an array, you can specify the 
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detailed occur time by daily, weekly or monthly. 

3. Set the effective date for a task in the Duration option. 

4. Check the Enable the task option to activate this task. If this option is unchecked, 

then the system will never execute this scheduled task. 

5.Click the Finish button. When a task has been added successfully, it will appear to 

the task schedule list in the main window. 

Modify Task Schedule 

Select a task that you want to modify from the Task schedule list in the main window, 

then click the Modify button on the toolbar. In the pop-up window you can modify 

the task name and frequency the task occurs.   

Delete Task Schedule 

Select a task that you want to delete from the Task schedule list in the main window, 

and then click the Delete button on the toolbar. When you delete an array, all task 

schedule related to this array will be deleted at the same time .  
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Views 

Event View 

Clicking View->Event View menu in the main window will display all events logged 

in the system. Those events are divided into three types: Information, Warning and 

Error.  

Checking one of the Filter options will display all the selected type of events in the 

following event list box. 

Clicking the Clear button will clear all events listed in the event list box and those 

stored on the remote system.  

Clicking the Save button will save all events listed in the event list box as plain text 

file. 

Clicking the Print button will print all events listed in the event list box. 

Icon View 

Clicking View->Icon View menu in the main window will display a window, showing 

different icons and its descriptions. 
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Additional Features 

HighPoint Storage Management Console provides the following additional features, 

which can keep maximum data integrity and consistency for your storage 

sub-system. 

 

Auto-detect Hot-plugged Disks 

If a disk is removed when it is running I/O operations or when some I/O errors occur 

in this disk, users will be informed. When the disk doesn’t run read/write operations, 

users can use the refresh function to rescan the devices. Similarly, when you insert 

a new disk, you can force the software to detect the disk using refresh function. 

Once a new disk is found, the software will auto-detect if there exists a broken array. 

If the capacity of the new disk suits the requirement of the array, users will be 

inquired whether to add the new disk into this array or not. If yes, the system will do 

it and perform auto-rebuild operation. 

 

Auto-rebuild Array 

The HighPoint Storage Management Service supports the auto-rebuild function. 

This can help users to auto-rebuild RAID 1,RAID 5,RAID 0/1 or RAID 1/0 array 

under the following circumstances. 

1. A spare disk exists in the spare pool. When a source disk in a RAID 1 array fails, 

a mirror disk will replace it automatically and the spare disk will become the mirror 

disk. If a mirror disk fails, the spare disk will auto-replace it to be the mirror disk. 

2. When a disk is added to a RAID 1,RAID 5,RAID 0/1 or RAID 1/0 array and the 

array resumes normal, the auto-rebuild function will be started. 

3. When the HighPoint Storage Management Service is enabled, the system will 

auto-rebuild all needed arrays at the same time. 

 

Integrity Checking 

When HighPoint Storage Management Console is launched, it will execute the 

following checking: 

1. If there exists a disabled array, user will be informed to delete it. 

2. If there exists a critical array, user will be prompted to rebuild it. 

3. If there exists a broken array and also exists a single disk, user will be prompted 

to add the single disk to the broken array. Then the array will be auto-rebuilt. 
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Glossary 

System 

A computer with HighPoint RAID Controller, driver for the controller,  and HighPoint 

Storage Management Service installed. Users can use HighPoint Storage 

Management Console to connect it and manage the RAID system.  

 

Controller 

A system may include one or more RAID controllers. A controller provides hardware 

control to devices. There are several channels on each controller.    

 

Channel 

A channel provides the connection between controller and device (array or physical 

disk). Each channel can attach a master device and a slave device. 

 

Device 

A device attached to the adapter. It can be an IDE hard drive or an ATAPI device such 

as CD-ROM or Tape. 

 

Event 

The detection of a disk failure will result in an event being recorded in the Event Log, 

which will trigger a critical warning message. 

 

Spare Disk 

A spare disk can be used as a replacement by a redundant array when a failure 

occurs. 

 

Spare Pool 

A logical container which includes several spare disks. When needed, the spare 

disks can be picked up sequentially. 

 

Dedicated Spare 

A spare disk that can only be used for a specified array. 

 

Initialization 

Initializing completely obliterates any information previously stored on the selected 

disks. 

 

RAID 

RAID is an acronym for Redundant Array of Inexpensive (or Independent) Disks. A 

RAID array is a collection of drives which collectively act as a single storage system, 

which can tolerate the failure of a drive without losing data, and which can operate 

independently of each other. The benefits of RAID can include: higher data transfer 
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rates for increased server performance, increased overall storage capacity for a 

single drive designation (i.e. C, D, E, etc.), data redundancy/fault tolerance for 

ensuring continuous system operation in the event of a hard drive failure. Different 

types of arrays use different organizational models and have varying benefits. The 

following outline breaks down the properties for each type of RAID array.  

 

RAID 0 (Striping) 

When a disk array is striped, the read and write blocks of data are interleaved 

between the sectors of multiple drives. Performance is increased, since the 

workload is balanced between drives (or “members”) that form the array. Identical 

drives are recommended for performance as well as data storage efficiency. The 

disk array’s data capacity is equal to the number of drive members multiplied by the 

smallest array member’s capacity. For example, one 1 GB and three 1.2GB drives 

will form a 4GB (4*1GB) disk array instead of 4.6 GB. The stripe block size value can 

be set logically from 1KB, 2KB, 4KB, 8KB, 16KB, 32KB, 64KB [Default], 128KB,  

256KB, 512KB, or 1024KB. This selection will directly affect performance. Larger 

block sizes are better for random disk access (like email, POS, or web servers), 

while smaller sizes are better for sequential access. RAID 0 arrays deliver the best 

data storage efficiency and performance of any array type. The disadvantage is that 

if one drive in a RAID 0 array fails, the entire array fails. 

 

RAID 1 (Mirroring) 

When a disk array is mirrored, identical data is written to a pair of drives, while 

reads are performed in parallel. The reads are performed using elevator seek and 

load balancing techniques where the workload is distributed in the most efficient 

manner. Whichever drive is not busy and is positioned closer to the data will be 

accessed first. Under RAID 1, if one physical drive suffers a mechanical failure or 

sector error, the other mirrored drive continues to function. This is called Fault 

Tolerance. Moreover, if a spare drive is present, the spare drive will be used as the 

replacement drive and data will begin to be mirrored to it from the remaining good 

drive. Due to the data redundancy of mirroring, the drive capacity of the array is 

only the size of the smallest drive. For example, two 1 GB drives which have a 

combined capacity of 2GB instead would have 1GB of usable storage when set up in 

a mirrored array. Similar to RAID 0 striping, if drives of different capacities are used, 

there will also be unused capacity on the larger drive. RAID 1 delivers the best 

performance of any redundant array type. 

 

RAID 5 (Stripe with Rotating Parity) 

This type of array is composed of independent data disk with distributed parity 

blocks. Each entire data block is written on a data disk; parity for blocks in the same 

rank is generated on Writes, recorded in a distributed location and checked on Reads. 

RAID 5 requires a minimum of 3 drives to implement. This type of RAID owns the 

highest Read data transaction rate. 
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RAID 0/1 (Mirrored Striping) 

Mirrored Striping combines both of the previous array types. It can increase 

performance by reading and writing data in parallel while protecting data with 

duplication. A minimum of four drives is needed for Mirrored Striping to be installed. 

With a four-drive disk array, two drives are striped together, and a second pair of 

striped drives is used to mirror the first pair of striped drives. The data capacity is 

similar to a standard mirroring array, with half of the total storage capacity 

dedicated for redundancy. An added plus for using RAID 0/1 is that, in many 

situations, such an array offers double fault tolerance. Double fault tolerance may 

allow your data array to continue to operate depending on which two drives fail. 

 

RAID 1/0 

RAID 1/0 is implemented as a striped array whose segments are RAID 1 arrays. It 

has the same fault tolerance as RAID 1 and the same overhead for fault-tolerance as 

mirroring alone. It owns the very high reliability combined with high performance. 

 

Disk Striping 

The technique of combining a set of disk partitions located on different hard disks 

into a single volume, creating a virtual “stripe” across the partitions that the 

operating system recognizes as a single drive. Disk striping can occur at the bit level 

or at the sector level and allows multiple concurrent disk accesses that can improve 

performance considerably. 

 

Disk Mirroring 

A fault-tolerant technique that writes the same information simultaneously onto two 

hard disks or two hard-disk partitions, using the same disk controller. If one disk or 

partition fails, information from the other can be used to continue operations. It is 

offered by most major network operating systems. It is also known as RAID 1. 

 

JBOD (Volume) 

JBOD is an acronym for Just a Bunch of Disks. It is used to refer to hard disks that 

aren't configured according to RAID -- a subsystem of disk drives that improves 

performance and fault tolerance. JBOD provides much more capacity (the sum of all 

the disks). If there is more than a single physical disk (not member of an array and 

not an ATAPI device or a removable disk), you can create a JBOD array. 


