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1. INTRODUCTION

Congratulations on your purchase of the Video Capture add-on card. This capture
card comes complete with the VCap utility for capturing still images and full-motion
video to create great multimedia presentations. This capture card can also serve as a
compatible video source for a wide variety of applications including video-
conferencing software for cyber-conferencing over the Internet!

1.1 Key Features

• Live video display in a full screen (640x480) or in a window.

• Video input sources: 1 mini-DIN, 1 composite video and 1 S-video input.

• Video systems supported: NTSC, PAL and SECAM.

• Full motion video and still image capture.

• Video display adjustable with brightness, Contrast, Saturation, and Hue
controls.

• Design is based on 32-bit PCI local bus (supports PCI bus- master, video data
through PCI to VGA display memory).

• No VGA feature connector required for compatibility with virtually all VGA
controller cards and systems with on-board video.

• No video frame buffer required for the best cost-performance ratio.

• Plug & Play supported for easy installation and setup.

• Software support for Windows 95 & 98:

∗ VCap utility: video source select, video display adjustments (brightness,
contrast, saturation, sharpness and hue), still image capture, full motion
video/audio capture.

∗ Windows driver: AVI
∗ Emulates scanners with TWAIN interface

• Software support for Windows NT 4.0:

∗ VCap utility: video source select, video display adjustments (brightness,
contrast, saturation, sharpness and hue), still image capture, full motion
video/audio capture.

∗ YUV422 Video Compression Codec drivers.
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1.2 System Requirements

• 32-bit PCI Local Bus system (with PnP)

• CPU 486DX 33Mhz or higher, Pentium CPU recommended

• 8MB System RAM or more, 16MB memory and 1GB hard disk recommended
for motion video capture

• Windows 95, Windows 98 or Windows NT 4.0

• VGA display in 32K, 64K or 16.7M color mode with hardware assisted video
playback acceleration and DirectDraw support

• Sound card and speakers required for audio support

1.3 Package Checklist

The package consists of

þ Video Capture Card

þ “Tekram Multimedia Utilities & Drivers” CD-ROM

Make sure all of the above components are accounted for before you begin the
installation.
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2. HARDWARE INSTALLATION

2.1 Installing the Capture Card

Important: Handle circuit boards by the edges or bracket. Touch the bare metal of
your computer case before handling any circuit boards to prevent static discharge
damage.

1. Turn OFF all power to your system, including any peripherals (printer, external
drives, modem, etc.).

2. Disconnect the power cord and the monitor cable from the back of the computer.
3. Remove the computer cover. Refer to your system user’s manual for

instructions.
4. Align the gold-fingered edge on your card with an empty PCI expansion slot and

gently insert it into place. You may need to remove the cover from the rear of
the PCI expansion slot that you selected.

5. Replace the screws to secure the card retaining bracket in place.
6. Replace the computer cover.

2.2 External Connectors

Connect your external video sources to the connectors of the capture card as shown
below.
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3. WINDOWS 95 & 98 SOFTWARE SUPPORT

3.1 Installing the Windows 95 Device Drivers

After the capture card is properly installed in the system, Windows 95 will
automatically detect the card as a Multimedia Device upon boot-up, and display a
“New Hardware Found” screen like the one shown below. Click on “Driver Disk
from Manufacturer”, insert the “Tekram Multimedia Utilities & Drivers” CD-ROM
into your CD-ROM drive and follow the on-screen instructions to install the drivers
for the capture card.

The driver is located under D:\C210\WIN9X\DRV

After the required files are copied, the system will ask if you wish to restart your
computer. Select YES to restart.

Note: The Windows 95 setup screen on your system may look different than the one
shown above if you have OSR2 / Windows 95 (B) installed.
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3.2 Installing the Windows 98 Device Drivers

1. After the capture card is properly installed in the system, power on your system.
Windows 98 will automatically detect the card as a PCI Multimedia Video Device
upon boot-up, and display a “New Hardware Found” screen, then “Add New
Hardware Wizard” dialog box will appear like the one shown below.

2. Then select “Search for the best drive for your device. (Recommended).”

3. Next select “Specify a location” then type in D:\C210\WIN9X\DRV

4. Follow the on-screen instructions to complete the driver installation.
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3.3 The Autorun Screen

After rebooting, insert the “Tekram Multimedia Utilities & Drivers” CD-ROM into
the CD-ROM drive. The Autorun screen will show up. If it does not appear, run
D:\AUTORUN (where D: is your CD-ROM drive).

Double-clicking the appropriate product model name C210 brings up the “Function
Selector” submenu.
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3.4 Installing VCap Utilities

1. Select Install Application on the Autorun Screen. The following dialog box
appears:

 

2. Select the default video system:

 - NTSC for U.S.A., Taiwan, Japan

 - PAL for West Europe, Mainland China, Hong Kong, Australia

 - SECAM for France, Russia

3. Click on the Continue button
after the installation is
complete. The “VideoCap
VCAP Utilities” program
group is added to your
Windows desktop, containing
the VCAP and WINCAM
application icons as shown:
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3.5 VCap Still Image Capture

This application is used for capturing still image files from you CCD, VCR,
camcorder or any video device that features either an S-Video-Out or Composite
Video-Out (RCA) connector. This program supports the Windows BMP file format.

Double click the VCAP icon to start the program.

The Control Panel is what you’ll use to configure and use the VCap application.

• POWER: Ends the VCap application.

• SOURCE: Selects video input source (CCD, composite video or S-video).

• FREEZE: Freezes / Unfreezes the full motion video screen for image capture.
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• FILE: Selects an image file name.

 
 
• CAPTURE: Captures image to hard disk with the filename you specified

previously, or with default image filename: “SAMPLE.BMP”.

• LOAD: Loads an image file for on-screen display.
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• SETUP: Brings up the hardware settings configuration screen.

∗ Input Viewport: Use this control if your image does not seem to center in
the VCap Window.

∗ System: Selects video system type for the current input source.
∗ Source: Selects video source. For proper operation, you must make sure that

the Video System is correctly set for any given Video Source. For instance,
your CCD camera is a PAL device, whereas a camcorder or VCR may be a
NTSC device.

• ONTOP: You can make sure your Video Window is always in front of your
other applications on the screen by clicking this button.



WINDOWS 95 & 98 SOFTWARE SUPPORT

13

3.6 WINCAM - Full Motion Video Capture/Playback

This program supports multiple Video Input Sources and allows you to make your
own digital movies in AVI file format.

Double click the WINCAM icon to start the program.

• DESTINATION: Selects video capture mode and captured image file name:

∗ STILL IMAGE (BMP) or
∗ MOTION PICTURE (AVI)

• HARD DISK: Displays available hard disk space and estimated size of image
file

• OPTION: Use to change default settings

∗ VIDEO/AUDIO: Selects a setting to be changed
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◊ Video Format: Selects the window size and the type of image or amount
of colors it will contain. The higher the number of colors and the bigger
the window size, the larger the size of the AVI file.

◊ Video Display: Adjusts the picture properties as well as the Input
Viewport. Use this control if your image does not seem to be centered in
the WINCAM window.
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◊ Video Source: Selects video input source and video system

◊ Audio Format: Allows you to specify the quality of sound you will
record in your movie. Enhancements like Stereo Sound will result in less
bandwidth being used for Video Recording. Therefore, unless sound is
important, keep the settings low or use the Video Only option.
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◊ Compression: Selects video compression algorithm (depends on
Windows version)

◊ Video Only / Both Video & Audio: Toggles between  video and audio
or video capture only. Click on the displayed option to select it as your
preference. The option not displayed is the one currently in use.

◊ Overlay Video Mode / Motion Picture Mode: Toggles between
Overlay or Motion picture mode (preview mode) to be used during
motion video capture. (Motion Picture Mode setting is recommended to
get the highest frame rate for motion picture video capture) Click on the
displayed option to select it as your preference. The option not displayed
is the one currently in use

 Note: If this option is not available, it means that your system support
only the Motion Picture Mode due to VGA driver limitation.

∗ FRAME RATE: Number of still video frames that can be captured and
converted in one second. A lower frame rate will produce less fluid motion,
but will result in a smaller AVI file.

∗ DURATION: Adjust your recording time.

• PLAY: Playback AVI files

• CAPTURE: Click to initiate video capture. After the movie is saved to disk,
you will be shown the amount and percentage of dropped frames. A dropped
frame is a frame that was not captured successfully.)



WINDOWS 95 & 98 SOFTWARE SUPPORT

17

3.7 TWAIN Driver

TWAIN (Technology Without An Interesting Name) is the most popular method of
capturing still images into normally non-image processing software programs like
PageMaker, PhotoShop, etc. The VCap’s TWAIN driver allows the Video Capture
feature to function much like a Scanner would in TWAIN-ready applications.

3.7.1 For PhotoShop image editor

• Select “Acquire” in “File” menu, then select “TWAIN” to capture still images
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• Click the “Capture” button in “Capture Twain” dialog box to capture an image
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3.7.2 For Corel’s PHOTO-PAINT

• Select “Acquire Image” from the “File” menu, then select “Acquire Image -
Acquire” to capture an image

• Click the “Capture” button in the Capture Twain dialog box to capture
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3.7.3 For Page Maker

• Select “Aldus Additions” in the “Utilities” menu, then select “Acquire image”
to capture an image
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4. WINDOWS NT 4.0 SOFTWARE SUPPORT

4.1 Installing the YUV CODEC Drivers

1. Insert the “Tekram Multimedia Utilities & Drivers” CD-ROM in your CD-ROM
drive.

2. On Windows NT control panel, click on "Multimedia".

3. Click on "Devices".

4. Click on "Add..".

5. Select "Unlisted or Updated Driver" and Click "OK".

6. Type D:\C210\NT40\DRIVER\ (where D: is your CD-ROM drive letter).

7. Follow the on-screen instruction step by step to complete the driver installation.

8. After the installation, you will see "YUV422 Codec" under "Video Compression
Codecs".

4.2 Installing the Windows NT 4.0 Device Drivers

1. Insert the “Tekram Multimedia Utilities & Drivers” CD-ROM in your CD-ROM
drive.

2. On Windows NT control panel, click on "Multimedia".

3. Click on "Devices".

4. Click on "Add..".

5. Select "Unlisted or Updated Driver" and Click "OK".

6. Type D:\C210\NT40\DRIVER\ (where D: is your CD-ROM drive letter).

7. Follow the on-screen instruction step by step to complete the driver installation.

8. After the installation, "VideoCap VCap Video Capture" will be displayed under
"Video Capture Devices".
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4.3 Installing VCap Utilities

1. Run Windows NT and insert the “Tekram Multimedia Utilities & Drivers” CD-
ROM in your CD-ROM drive. The  Autorun screen will show up. If it does not
appear, run D:\AUTORUN (where D: is your CD-ROM drive). See page 8.

2. Select the appropriate product model name C210.

3. Select Install Application. The following box will appear.

 

4. In the Installation Directory, type the drive and directory where you want the
software installed. The default path is C:\VCAP.

5. Click Continue to start copying of the files.

6. Click on the Exit button after the
installation is complete. The “VideoCap
VCAP Utilities” program group is added to
your Windows desktop, containing the
application icons as shown:

Use the Uninstall program when you want to
remove this application program.
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4.4  Using the VCap Utility for Windows NT 4.0

This application is used for capturing still images and full-motion video plus audio
from any video device that features either a mini-DIN, an S-Video-Out or a
Composite Video-Out (RCA) connector.

The VCap utility saves the captured still image as DIB file format. The video is
saved as AVI file format.

The topics in this chapter are arranged in such a way as to take you through the
steps of capturing a still  image or motion video.

4.4.1 Application Window

Double-click the VCap icon from the “VideoCap VCAP Utilities” program group to
start the program. The application window appears:

• Title and Information Bar: Contains the program name, the standard Windows
Minimize, Maximize and Exit buttons. Also displays information about actions
taking place in the window.

• Menu Bar: Lists the five menus of the program.

• Display Area: The “screen” where your media plays.

To exit from the program, either click the Exit button on the Title Bar or choose
Exit from the File menu.
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4.4.2 Selecting the Video Source

From the Options menu, choose Video Source. The Video Source dialog box
appears:

• Video Connector: Select video input
source (Mini DIN, Composite or S-
video).

• Video Standard: Select video
system type for the current input
source. For proper operation, you
must make sure that the Video
System is correctly set for any given
Video Source. For instance, your
CCD camera may be a PAL device,
whereas a camcorder or VCR may be
a NTSC device.

4.4.3 Selecting Overlay / Preview Mode

Select Overlay or Preview mode from the Options menu. In Overlay mode, video is
transferred directly from the capture card to the memory of the display card without
using any CPU resources. This results in better on-screen viewing. However, the
capturing operation automatically uses the Preview mode, therefore, the quality of
the captured image or video is the same regardless of the setting.

The Overlay mode is dependent on your VGA display driver (linear frame buffer)
support from your display card manufacturer. Select the Overlay mode if it is
supported.
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4.4.4 Setting the Video Display Size and Format

From the Options menu, choose Video Format. The Video Format dialog box
appears:

• Image Format: Select the image
type and the amount of colors it
will contain.

• Image Dimensions: Selects the
image display size.

Note: The higher the number of
colors and the bigger the window
size, the larger the size of the AVI
file. It is recommended that you keep
the image size at the default and
colors not higher than 16 bits.

4.4.5 Adjusting the Picture Properties

From the Options menu, choose Video Display. The Display Control dialog box
appears:
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• Picture Properties: Drag the slide bars to adjust the brightness, contrast,
saturation sharpness and hue of the displayed video.

• Input Viewport: Use these controls if your image does not seem to center in the
application Window.

4.4.6 Creating New Palette

If the image type of the displayed video is 256 colors (8-bit color) or less, setting a
new color palette may improve the picture dramatically.

From the Options menu, choose Make Palette to create a new palette. The following
dialog box appears:

Colors: Specify the number of colors to be contained in the palette.

Frame: Specify how many frames from which the color is to be selected for the
palette.

4.4.7 Changing the Settings for Video Capture

Choose Capture Settings from the Capture menu to change the preferences for video
capturing. The dialog box appears:

* All the values will return to default after exiting the program.
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• Frame Rate: Number of still video frames that can be captured and converted to
digital format in one second. A lower frame rate will produce less fluid motion,
but will result in a smaller AVI file.

• Enable Capture Time Limit: Check this box to specify the maximum recording
time.

• Capture Audio: Check this box to capture audio with the video.

• Video Buffers: If the memory capacity allowed, more buffers will result in
higher video transfer rate. It is recommended that you leave it at the default
value.

• Key to Abort Capture: Select the key to be used for ending video capture.

• Mouse to Abort Capture: Select the mouse button to be used for ending video
capture.

• Hit OK to Capture: By default the
capturing begin as soon as you choose the
capture command from the Capture menu.
Click this check box to have a dialog box
appear before the capturing start for re-
confirmation.

• Use DOS Memory: With this option
enabled, the program will try to use the DOS memory for faster performance.
However, the memory capacity is limited to under 1 Megabyte.
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4.4.8 Selecting the Audio Format

With the Capture Audio option enabled (See the previous section), the Audio
Format command from the Options menu allows you to specify the format of sound
you will record with your video. The following dialog box will appear:

Enhancements like Stereo Sound will result in less bandwidth being used for Video
Recording. Therefore, unless sound is important, keep the settings low or capture
only the video.

4.4.9 Selecting the Video Compressor

From the Options menu, choose Compression to select the video compression
algorithm. The dialog box appears:
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• Compressor: Selects the compressor to be used.

• Compression Quality: Sets the compression rate. The higher number will result
in less distortion but bigger AVI file.

• Key Frame: The bigger the interval between the key frames, the more the
distortion will be.

• Configure: Configures the settings for the selected compressor.

4.4.10 Allocating Memory Space

Digital video takes up a large amount of hard disk space. Before you start to capture
a movie, check out the available hard disk space and set aside a memory size for the
captured file by selecting the Allocate File Space from the File menu.

4.4.11 Specifying the File Name for Video Capture

Before capturing a motion video, you should first decide the name of the captured
file and the location on the hard drive that the image will be stored in, or the file
will be saved to the default name and path c:\capture.avi

Choose Set Capture File from the File menu. The following dialog box appears:
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4.4.12 Capturing Motion Video

Click Capture Video under the Capture menu to initiate video capture. After the
movie is saved to disk, you will be shown the amount and percentage of dropped
frames. After the capturing is complete, the video display will remain still. Click
Preview or Overlay from the Options menu to continue the playing.

4.4.13 Capturing a Still Image

Click Capture Frame from the Capture menu. This captures image to the hard disk
with the default path and filename: c:\vcap.dib.

4.4.14 Copying to the Clipboard

To copy the displayed image onto the Clipboard, choose Copy from the Edit menu.
The image is captured as a bitmap and can be pasted to any application supporting
the Windows software Clipboard function.


